No architectures to compile for (ARCHS=arm6 arm7, VALID_ARCHS=armv7)

Go To


I am constantly getting below error while building app:

No architectures to compile for (ARCHS=arm6 arm7, VALID_ARCHS=armv7).

I tried adding arm6 arm7 to architecture but didn't work. I also tried just arm6 and arm7, but still not.

Also, I'm setting deployment target to 4.3 iPhone. I have Xcode version 4.3.1.

Please help!

2012-04-04 06:22
by iOSDev
At the end of all warnings I am getting all apps should include an armv7 architecture (current ARCHS = "" - iOSDev 2012-04-04 06:38
Why all the down votes - i_am_jorf 2012-10-01 22:50
Set "Build Active Architecture Only" to "NO" for all your dependent libraries and framework, and your target - Emmy 2013-01-25 16:02
What does build active architecture only mean - user4951 2013-11-14 10:53
Hey @iOSDev! Could you accept the answer that helped you, there are no accepted answers to this question at the moment.. - Neeku 2014-06-04 16:51


You must take two steps:

  • Go to Project Target > Build Settings > Architectures Delete whatever you see there, and then add these rows one by one:

    armv6 armv7

There are no 'save' buttons there, so what I do, is adding another blank row, pressing enter, removing it, and then clicking out somewhere else, so that I make sure I have both of them added:

enter image description here

  • Now go to the AppName-Info.plist file, and look for the key "Require device capabilities" and delete it all.

Now it's done.

2012-06-12 09:45
by Neeku
nice it helped me than - Mohit 2014-07-31 09:13
this one helped me thx kudo - Niranjan Balkrishna Prajapati 2014-12-18 10:55


set "Build Active Architecture Only" = NO this worked for me after upgrading an old project to xcode5

2013-10-26 13:44
by roocell
this is it! thanks - MaKo 2013-12-05 02:58
But if we open project in Xcode 4.x then the error pops-up - Jayprakash Dubey 2014-04-01 14:10


That works fine for me:

Set architectures to "Standard (armv7,armv7s)" and after set manually Valid architectures to armv7 armv7s

enter image description here

2013-06-27 15:26
by OrdoDei
This one worked and +1 - Jayprakash Dubey 2014-04-01 14:12


Not arm6 and arm7, try by adding armv6 and armv7 as architectures.

2012-04-04 06:25
by Neo
No, I am not adding "and" in between - iOSDev 2012-04-04 06:27
It's not the AND that's important, it's the V - armv - jrturton 2012-04-04 06:58


Add architectures only armv7. Remove armv6 then try it.

2012-04-04 06:36
by Rajesh
Tried but didn't work :( Badly stuck no - iOSDev 2012-04-04 06:48
I also tried Not working for me with xcode 4.5 and iostarget 5.1 - Karthik 2013-04-18 05:45


I am using the latest Xcode and iPhone5. I had it set to armv7s and armv7. It took care of my issue which was the No architectures to compile for (ONLY_ACTIVE_ARCH=YES, active arch=armv7s, VALID_ARCHS=armv6 armv7) error .

2013-03-26 14:38
by flyers


To include 64 bit: Set architectures to "$(ARCHS_STANDARD_32_64_BIT)" and after set manually Valid architectures to armv7 arm64. My Xcode version was 5.1. Base SDK was iOS 7.1 Deployment target was 6.0.

In another setting configuration: Set architectures to "$(ARCHS_STANDARD)" and after set manually valid architectures to armv7 arm64. My Xcode version was 6.2. Base SDK was iOS 8.2 Deployment target was 6.0.

2017-05-31 11:58
by kalan