Board Support Library link error in ARM project

Go To


I have an ARM project (for Generic ARM9 Device) in Code Composer Studio ver5 (in fact it is the modified eclipse). Properties of project:

Device:         Generic ARM9 Device
Compiler        version: TI v4.9.1 
Output format:  eabi (ELF) 
ARM Linker File Search Path: "C:/workspace/bsl/lib/evmomapl138_bsl.lib" 

And I got linking error

"C:/ti/ccsv5/tools/compiler/tms470/bin/cl470" -mv5e --code_state=32 --abi=eabi 
-me -g --diag_warning=225 --display_error_number -z -m"" 
-i"C:/ti/ccsv5/tools/compiler/tms470/lib" -i"C:/ti/ccsv5/tools/compiler/tms470/include"
--reread_libs --warn_sections --rom_model -o "prog.out"  "./main.obj" 
-l"C:/workspace/bsl/lib/evmomapl138_bsl.lib" -l"libc.a" "../lnk.cmd" 

undefined        first referenced
symbol              in file     
---------        ----------------
I2C_init         ./main.obj      
LED_turnOn       ./main.obj      
LIDD_init        ./main.obj      
LIDD_writeString ./main.obj      
USTIMER_delay    ./main.obj      
USTIMER_init     ./main.obj      

error #10234-D: unresolved symbols remain
error #10010: errors encountered during linking; "prog.out" not built 

All definitions for these functions are in evmomapl138_bsl.lib. 100%

P.S. Also I tried to put "evmomapl138_bsl.lib" in "Include library file or command file as input" and path to this file "C:/workspace/bsl/lib" in "Add to library search path"

Also I tried to use "\" inside "/"

What's problem here? Thank you.

2012-04-04 05:59
by Myosotis
It's not very constructive but trying to do Linux development from a Windows machine is doomed from the start. You will see nothing but pain and suffering - Kristof Provost 2012-04-04 08:00
lol. Linux - is pain and suffering.. - Myosotis 2012-04-05 09:36


evmomapl138_bsl.lib is a C6000 library. So it can't not work for the ARM. There is OMAPL138_StarterWare library (it can be found on So this library has libs both for DSP and ARM chipsets

2012-04-05 09:41
by Myosotis