adb logcat hangs with "waiting for device" message

Go To


When I type adb devices command on terminal, it shows device is connected

List of devices attached

0123456789ABCDEF device

But when I type adb logcat command, it hangs with below message

waiting for device

Can anybody tell me what is the problem behind this? I test the device on cts.

2012-04-04 05:41
by Android Boy
can you check if the adb devices shows your device to be offline - Deva 2012-04-04 05:43
yea, Its show only device stopped, not offlin - Android Boy 2012-04-04 05:48
Can you add the output of the "adb devices" in you question please - Deva 2012-04-04 05:57
Its allready added, Waiting for device many time - Android Boy 2012-04-04 05:59
In your question you say you see inforamtion about devices "When I type adb devices command on terminal then I show the information about device" . Now you say you see " Waiting for device" when you type "adb devices" . Are you sure - Deva 2012-04-04 06:05
oh sorry, after type adb devices I see List of devices attached 0123456789ABCDEF device and after typing adb logcat I see waithing for devic - Android Boy 2012-04-04 06:10
Can you add full output of the "adb devices" in you question please - Deva 2012-04-04 06:14
Now I edit my questio - Android Boy 2012-04-04 06:19


I am not pretty much sure if this works for you but can you please try the steps below:

# Kill and restart      
$ adb kill-server      
$ adb start-server     
 daemon not running. starting it now *      
 daemon started successfully *         

# Device appears, but is listed as offline

$ adb devices      
$ adb logcat
2012-04-04 06:43
by Deva
I already try this, It doesn't work...!! - Android Boy 2012-04-04 07:43
Changing the USB connection type from Charging to File Transfer did the tric - Warface 2017-11-07 13:58


I have also experienced similar problems I think I solved it by having the USB debugging option switched on within Developer Options in Settings.

REPEAT The following steps above, it should work!

2013-01-29 16:48
by Karbon62


I had this same problem on Ubuntu 12.04. Thankfully MickeyMicro had the solution that worked for me:

  1. Run the command: gksudo gedit /etc/udev/rules.d/51-android.rules

  2. Add the following line to the blank file

SUBSYSTEM=="usb", ATTR{idVendor}="2080", MODE="0666" (I used this one on 12.04)

SUBSYSTEM=="usb", SYSFS{idVendor}="2080", MODE="0666" (Another recommended for 10.04)

  1. Save and close gedit.

  2. Run the command: sudo chmod a+rx /etc/udev/rules.d/51-android.rules

  3. Restart the system.

  4. Run the command: sudo sh -c "mkdir -p ~/.android; echo 0x2080 > ~/.android/adb_usb.ini; adb kill-server; adb devices"

  5. Verify that you have permissions to access the device. adb devices should return normal response, rather than a "???????????? no permissions" message.

2012-08-31 18:24
by Bobby


When I have experienced this infinite "waiting for device" on Windows I had simply forgotten to enable usb-debugging in the developer options of my device.

2014-05-14 15:24
by Kaiserludi


Here is yet another potential method to solve this -- in the past, the above solutions will work, but in my case, this time, this was the thing that fixed it:

  1. Plug device into USB
  2. Settings -> Developer Options
  3. Revoke USB Debugging Authorization
  4. Unplug Device
  5. Repeat Step 1
  6. Authorize Device
  7. Repeat Steps 4&5

adb devices should now show device

adb logcat should now output logs from device

2015-06-01 05:10
by Geremy
What does "Authorize Device" mean? This all sounds good, and all the rest made sense, but I have not a clue what that means .. It's not in Android settings - www-0av-Com 2017-08-13 22:46
Its a dialog that the Android device should throw up automatically for you upon connect - Geremy 2017-08-16 21:33


What OS are you using? It can be a variety of different reasons. Did you make sure you only have either the emulator running or a device attached? If so, you can direct your adb command by using the -d or the -e flag.

2012-04-04 06:03
by Chris A
I use Ubuntu 11.04 O - Android Boy 2012-04-04 06:10


I got Nexus tab today and I had to go to Settings -> About Tablet -> (tap 7 or 8 times) on Build Number.

Then 'Developer Options' showed up above 'About Tablet'.

Next in Developer Options, after enabling USB Debugging I was able to get the logs

For Mac Users:

cd /Applications/Android/sdk/platform-tools

./adb logcat

2013-12-15 20:28
by Omkar Nisal


I had similar problem on Galaxy S3, with adb running on Ubuntu 11.10 OS. In my case, If I reconnect the device (pull the USB connection and reconnect it), the log cat starts working. This happens only for the first time I connect the device after powering it up. Once logcat starts working, then it continues to work smoothly, without needing to reconnect.

2012-07-02 11:47
by Oak Bytes
the same worked for windows 10 also (x64 to be specific). Just make sure u have got an updated version of ad - BiLaL 2018-09-02 10:03


This happend to me on OS X mountain lion. To fix it I had to
open Activity Monitor, filter all processes named "adb" and force quit them (I had 3 running). Then reconnect the device and everything was working again.

2012-08-23 12:28
by UVRadiation


On my Samsung Galaxy S4 I had the same problem but after 10-20 seconds a dialog pops up on the phone where I have to accept the debug request

2014-03-12 09:25
by smerlung


I had a similar problem, but for different reasons. My issue came from programing usb accessory on android, which changes the vid/pid when in accessory mode. The solution for me that worked was the following:

  1. Connect the phone
  2. Run the usb host side accessory mode commands (Example website: )
  3. Phone should have reconnected in accessory mode (Ensure the PID has adb: 0x2D01)
  4. adb kill-server
  5. sudo adb start-server (This caused the phone to re-ask auth permission)
  6. adb logcat (In my case I wanted to watch the logs, this now worked in accessory mode)
2015-09-04 23:13
by Luke Dupin


In my case, I was using an old version of adb, make sure you have the latest version of adb. You can download here, extract and run straight within the folder ./adb.

2018-03-15 20:03
by Elijah Lynn


Please go to the developer options on the phone and click "Revoke USB debugging authorization"

Enable it again and try to get the logs. This is basically waiting for the device to get connected. Make sure to authorize USB access from device as well.

2019-01-01 14:31
by Vishnu Ashok