Can't Access Admin Control Panel or Deploy App Engine App

Go To


So, about two or three hours ago, I was successful working on and able to deploy my app engine app from Eclipse to App Engine. Up until about an hour ago, however, I have been unable to do so. In Eclipse, when I attempted and failed the first time to deploy the app, the progress froze at 20-something% ("Precompiling...") for about 10 minutes returning an error telling me to disable precompiling in appengine-web.xml, which I did. Then, after another attempt, it froze for about 10 minutes on the step immediately before when precompiling would happen ("Cloning Application files"), returning a 500 server error from app engine. I tried with another app engine project I have deployed successfully today and it failed the same way.

To see what was going wrong, I attempted to login to the admin panel on, but when I clicked one of my apps in "My Applications" it took about 1 minute to load and gave me a 403 error. When I went back to try again, it took 2 minutes to load and gave me a Server error (which I assume would be a 500 server error but it didn't say, just black text and a link to report). The third time I tried, I got an error page titled "Try Again (503) - My App".


  • I am using a Google Apps account.
  • The projects are new (created today)
  • The projects were deployable earlier
  • The only changes made to the project that gave the first error were added HTML/CSS files
  • No new changes were made to the 2nd project prior to my attempt to deploy after the 1st failed
  • The only thing that maybe I could think of is I added a domain (registered and configured through Google Apps) to one of the projects in between it working and not working

Thanks in advanced!

Edit: Something that first came to mind was an outage of some sort but there appears to be no scheduled maintenance and no reported outages.

Edit: It appears that I am now able to access the Dashboard for my applications but deployment is now failing the same way (500 Server Error)

2012-04-04 05:14
by Brandon
I am facing the exact same problem. Cant access as it is continuously returning 500 error. My app that is already deployed on works fine though. But I need access to the dashboard straight away!! Now that I see this issue with another user too I am sure App Engine is down. Cant seem to find a place to raise alarms :- - Sumeet Pareek 2012-04-04 05:52
The app engine application dashboard just came up without errors. Guess the outage is taken care of - - Sumeet Pareek 2012-04-04 05:53
I fixed this for myself and will add it as an in-depth answer when I'm able to in 6 hours (don't have at least 100 rep /:). Essentially, I just ran appcfg rollback on the project outside eclipse and redeployed it - Brandon 2012-04-04 06:26


This was a temporary problem. I saw it as well, and a few other complained about it on the mailing list. The problem eventually went away.

2012-04-04 14:21
by dragonx
Oh. Thats strange, maybe i didn't have to use "appcfg rollback". Oh well, its working now and I'm happy. ( - Brandon 2012-04-04 22:34
yeah, it wasn't related to anything you did. it was just busted on Google's side - dragonx 2012-04-04 23:22


So this is how I fixed it:

What I did just to test was create a brand new sample project and deploy it as the first application to app engine, but I got another error that told me another admin was updating this application and in order to fix this transaction, I had to run "appcfg rollback" on the app. So, I searched for appcfg in the eclipse plugins folder, opened a command window there and ran:

appcfg rollback "path_to_project_in_eclipse_workspace\war"

I then deployed successfully the new test application and then deployed the original application and everything worked smoothly.

Not exactly sure what happened. A transaction could have just failed and screwed up the app on the app engine servers but the rollback command worked (Thank God!) and now I'm not having any problems.

Hope this can help someone else!

2012-04-04 22:32
by Brandon