What's the wrong when Zend route don't work on Ubuntu 11.10

Go To StackoverFlow.com


I have everything same in 10.04 LTS, local in parallels 7 On ec2 instances I have same 11.10 setup, it works perfectly. The only difference in local setup is I symlink /media/psf/Home/Sites to /var/www but this works fine on the other ubuntu 10.04 in the same parallels.

I get errors like can't find class in modules/ and models/services and those folders. So it seems like autoloader don't work properly on modules. So I'm assuming that these parts don't work

resources.modules = ""
resources.frontController.moduleDirectory = APPLICATION_PATH "/modules"

But as I said it all works on the ec2 instances. Thanks

2012-04-04 01:38
by Faisal
The route question might be just another issue when zend cant load a module by router, so its mostly the autoloadin - Faisal 2012-04-04 01:39
You might also want to drop the "nginx" tag and maybe replace "parallels" with "virtualization" or something more general because it would affect a VirtualBox user just the same - Wil Moore III 2012-04-04 18:45


As a test (temporarily), try copying the entire site away from /media/psf/* to something like /var/www/*.

If that works, the problem is likely a case-sensitivity issue. Is your host machine OSX or Windows?

2012-04-04 04:05
by Wil Moore III
Ughhh it worked, I was always thinking of doing this but I was too lazy. Host is OSX, I have same setup with ubuntu 10.04, but its working perfectly fine. Thanks, anything I can do so I can load it from shared folder just like the other one - Faisal 2012-04-04 14:30
Yes, you can most definitely get this to work. OSX/Windows (by default) have case-insensitive filesystems (you'd think OSX would do better). You likely need to create your "modules/*" directories again taking care to ensure you are creating them in the proper case. Try not to have to rename based on case...that will just confuse the issue, especially if you are using SVN. If you are, bless your heart - Wil Moore III 2012-04-04 16:27
hmm recreating didn't wor - Faisal 2012-04-04 17:19
Try this: resources.frontController.moduledirectory (notice the lower-case D). It may make a difference...may not. I've just noticed that this is how I have it in all of my projects - Wil Moore III 2012-04-04 18:43
nop, tried it with others that is like that. Didn't work too. I have basically given up on this. I could try mounting differently too but then thats wasting the sharing feature of parallels - Faisal 2012-04-05 15:45
Well that's a pain. Sorry it didn't work out. I'm not super familiar with Parallels (purchased it when I bought my mac just to find out that VirtualBox was better and cheaper) but I've had good luck with VirtualBox. The other alternative is to rsync your changes to your virtual machine. If you go that route, I recommend a Ruby tool called Guard which you can setup to watch for changes at which point it can execute any command you desire. If you go with VirtualBox, you might also look at using it with Vagrant as it is perfect for your development scenario - Wil Moore III 2012-04-05 20:59
Here is the link to Vagrant: http://vagrantup.com - Wil Moore III 2012-04-05 21:00
thanks, I use to use virtualbox, I might try it again when I really need to upgrade and still don't work. Thanks AND Wow with vagrant, I'll definitely try it when I get the chance. Never heard of it. This looks good to be some sort of standard environment that I have been trying to standardize with my team. cool - Faisal 2012-04-07 00:44