Instaling XCode 3.2.5 on OSX 10.6.8 produces the error - "The operation couldn’t be completed. CSSMERR_TP_CERT_EXPIRED"

Go To


When installing XCode 3.2.5 on OSX 10.6.8, I get the following error message in /private/var/log/install.log

Failed install preflight: Error Domain=PKInstallErrorDomain Code=102 UserInfo=0x1d9a30 "The package “iPhoneSDKTools.pkg” is untrusted." Underlying Error=(Error Domain=NSOSStatusErrorDomain Code=-21 47409654 UserInfo=0x1dbe90 "The operation couldn’t be completed. CSSMERR_TP_CERT_EXPIRED")

Adding question and answer for others searching on a different version of XCode.

2012-04-03 22:30
by Ralph Willgoss


I also had the problem installing the downloaded version of XCode 3.2.6 from Apple, checked the log and got the "untrusted" error and found my way here to discover the Package Signature issues. Some of those tools only work on Lion though, and much of this is catch 22 for people as we are using 10.6 and so have to use Xcode 3.2.6...

Anyway, to cut a long story short, change the system date back to Feb 2012 (before the certs expired in March 2012) and then install.... worked fine for me, such a simple solution - far too long to get there though...

EDIT : Sorry, only just clicked though to see your link about the date/time, I went straight to the repackager. If it's okay, I'll leave this here as it gives a direct answer to the question for people like me who have just found this on Google etc

2012-04-20 19:59
by dave heywood
thanks for contributing! every bit helps :- - Ralph Willgoss 2012-06-15 15:35
Hi Dave,Thank you so much. Your solution also applicable for Xcode 4.0 (final) for Mac Os X 10.6.6i - datnt 2012-12-22 04:01
Dave, due to popularity of your answer, I've marked yours as correct :- - Ralph Willgoss 2013-01-10 09:21


I found a solution for XCode 4.2 in this recent stackoverflow post.

Following the instructions to flatten the image worked for XCode 3.2.5 too:

2012-04-03 22:32
by Ralph Willgoss