"Edit and Continue" doesn't work - VS2010 with TFS - Locked files in the Solution

Go To StackoverFlow.com


In my Visual Studio 2010 the Edit & Continue debug functionality with a specific Solution under TFS doesn't work. There's no error, but when the execution of the application stops at the breakpoint, I can't modify the files with the code. It seems that TFS has locked the files for my user.

I have tried:

1) To ensure Read/Write permissions to the files

2) To verify that all projects was built strictly for x86 (I have Win7 64 bit)

3) To disable the check JIT in Options/Debug

4) I also tried to restore to the initial conditions the VS 2010 settings with Tools/Import-Export Settings

5) I have tried to import the settings from a pc of a my collaborator, in which Edit & Continue works well

With other solutions, not stored in TFS, I have no problem. How can I allow Edit & Continue for this solution?

2012-04-03 20:36
by lamarmora
Are you building your application for AnyCPU on a 64 bit machine - Steve 2012-04-03 20:47
@Steve: no I'm building for x86 and, yes, I have Win 7 64 bit - lamarmora 2012-04-03 21:05
I hope that this question could help you to pinpoint the problem. Buonanott - Steve 2012-04-03 21:59


Ok the issue was a Visual Studio addin to work with SQL Compact. I have seen that there isn't issues if I sart Visual Studio in safe mode.

2012-04-28 22:45
by lamarmora